650 Odometer on Crack!! - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
General V-Strom Discussion Talk about all things V-Strom not limited to just one of the above models

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-02-2014, 02:40 AM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Sep 2014
Location: Vancouver Canada
Posts: 2
650 Odometer on Crack!!

I have a 2010 Dl 650 and I noticed today that a ride of less that 200km added up on the odometer to almost 1000 km! Has anyone else had this problem? Solutions? Thanks in advance.

Last edited by greywolf; 09-02-2014 at 11:27 AM.
Artemis girl is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-02-2014, 11:26 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I've never heard of that one. The speedo and odo take inputs from a sensor on the front axle next to the left fork leg. It's #11 at 2011 Suzuki V-Strom (DL650) SPEEDOMETER (DL650 L1 E28) | MRCycles

The sensor sends a pulse every time on of the four lobes passes the fixed part of the sensor. There isn't anything I can think of that would make it send extra pulses. The speedometer uses the same pulses. Is it reading okay? If you got the reading from a trip odometer, maybe you forgot to reset it.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
post #3 of 6 Old 09-02-2014, 12:20 PM
Stromthusiast!
 
Tnkrplt's Avatar
 
Join Date: Mar 2008
Location: Mechanic Falls, Maine
Posts: 1,195
Garage
Send a message via Yahoo to Tnkrplt
I know my 08 was 3% off when compared to my GPS, but that's a bit excessive...lol


Sent from Motorcycle.com Free App

13 Wee
09 Yamaha WR250R (Sold)
08 Stealth Wee (Sold)
04 Savage (Sold)
Tnkrplt is offline  
 
post #4 of 6 Old 09-03-2014, 11:25 AM
Stromthusiast!
 
MikeB's Avatar
 
Join Date: Mar 2008
Location: California Gold Country
Posts: 5,444
Did this just happen suddenly? Seems pretty strange on a bike several years old.

2008 DL650A
2016 KTM 390 Duke
"All you need in this life is ignorance and confidence, and then success is sure."
- Mark Twain, 1887
MikeB is offline  
post #5 of 6 Old 09-03-2014, 10:39 PM
Stromthusiast!
 
teevee's Avatar
 
Join Date: Jul 2010
Location: Miami/Managua
Posts: 1,323
Garage
maybe it was her trip meter she forgot to reset...

'08 DR650, '07 DL1000
"And anyways, if they don't have motorcycles in heaven, I'd rather go to hell. I'm pretty sure they will have loads of them there." (deelip, 2016)
teevee is offline  
post #6 of 6 Old 09-04-2014, 11:25 AM
Stromthusiast!
 
Join Date: Jul 2013
Location: Close to you
Posts: 639
Maybe the bike was on speed.................?
dogdaze is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome