Anyone done a TPS adjustment for a 2019XT? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2017+ DL650A - 2017 (L7) and later

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-22-2019, 03:00 AM Thread Starter
Stromthusiast!
 
V650's Avatar
 
Join Date: Jun 2019
Location: Australia
Posts: 32
Anyone done a TPS adjustment for a 2019XT?

I am trying to test my tps but I don't have the 'dash' or hyphen next to the c00 code. Does anyone know the procedure for this model?20190722_144459_1563778783211.jpg
V650 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-22-2019, 06:06 PM
Stromthusiast!
 
Join Date: Jun 2015
Posts: 161
but why, my 2019xt runs perfectly....
offnote is offline  
post #3 of 6 Old 07-22-2019, 08:08 PM Thread Starter
Stromthusiast!
 
V650's Avatar
 
Join Date: Jun 2019
Location: Australia
Posts: 32
Quote:
Originally Posted by offnote View Post
but why, my 2019xt runs perfectly....
Lucky you! I just want to make sure my throttle snatch issue is not an out of spec TPS.
V650 is offline  
 
post #4 of 6 Old 07-25-2019, 03:47 PM
Stromthusiast!
 
RoadWarrior1978's Avatar
 
Join Date: May 2019
Posts: 12
Garage
I tried to do the same with my L8 1000 and go the same result, I can only make the assumption it's to do with the latest round of emissions legislation.

I've also noticed that any time a fault is logged it will take three starts and successful runs before the engine management light will extinguish, in the same way as any OBDII equipped car would. I know here in the UK this is the result of EURO 4, it may well have been applied elsewhere as a blanket measure but that's just a guess.

It's not yellow, it's "YELLOW!!!!"
RoadWarrior1978 is offline  
post #5 of 6 Old 07-25-2019, 08:43 PM Thread Starter
Stromthusiast!
 
V650's Avatar
 
Join Date: Jun 2019
Location: Australia
Posts: 32
Thanks for that info. Yeah mine is euro 4. I'm assuming adjustment is still possible but it would be using a voltmeter with a break out harness or directly to the pin on the ecu.
V650 is offline  
post #6 of 6 Old 07-26-2019, 01:48 AM
Stromthusiast!
 
RoadWarrior1978's Avatar
 
Join Date: May 2019
Posts: 12
Garage
That's most likely the case. I've tried to find the necessary specs but not had any luck yet, I bet it'll be in the latest edition of the FSM.

It's not yellow, it's "YELLOW!!!!"
RoadWarrior1978 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome