C16 FI code - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2017+ DL650A - 2017 (L7) and later

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-25-2019, 11:35 AM Thread Starter
Stromthusiast!
 
Eran Kaufman's Avatar
 
Join Date: Apr 2019
Posts: 12
Garage
C16 FI code

I had C16 (front speed sensor) cause the sensor broke off, this triggered the Check engine and ABS lights to light all the time.
i just replaced the sensor, and the FI still blinks as before (i didn't ride the bike) do i need to reset the fault or it will go away once i'll ride and the ECU will see a signal from the sensor?
Eran Kaufman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-25-2019, 12:41 PM
Stromthusiast!
 
Join Date: Nov 2016
Location: Greenville, SC
Posts: 419
I haven't had that specific fault code, but my experience has been that these check engine faults don't clear themselves after your problem is fixed. I have been able to clear out mine by using the following steps.
  • Ride for 10-20 miles
  • Pull over and put the bike into dealer mode (google how if needed)
  • Code will now show as changed to C00
  • Turn the bike off, on and off while in dealer mode

Done!
brock29609 is offline  
post #3 of 4 Old 05-25-2019, 12:53 PM Thread Starter
Stromthusiast!
 
Eran Kaufman's Avatar
 
Join Date: Apr 2019
Posts: 12
Garage
Quote:
Originally Posted by brock29609 View Post
I haven't had that specific fault code, but my experience has been that these check engine faults don't clear themselves after your problem is fixed. I have been able to clear out mine by using the following steps.
  • Ride for 10-20 miles
  • Pull over and put the bike into dealer mode (google how if needed)
  • Code will now show as changed to C00
  • Turn the bike off, on and off while in dealer mode

Done!
Thanks
i'll try that
Eran Kaufman is offline  
 
post #4 of 4 Old 05-26-2019, 02:58 PM Thread Starter
Stromthusiast!
 
Eran Kaufman's Avatar
 
Join Date: Apr 2019
Posts: 12
Garage
So just to update, after a short ride engine off for refueling, lights are off
Eran Kaufman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help, Fuel Injection code and I'm on the road WingVetteStrom DL650A - 2017+ 19 02-24-2019 02:45 PM
How to clear FI code?? brock29609 Maintenance, Tech and Products. 7 07-23-2018 07:46 AM
C-28 fault code tdewitt DL1000 from 2002-2012 7 06-03-2014 08:27 AM
STVA & TBS, now have C28 error code penzone V-Strom Service and Maintenance Questions and Discussions 15 03-29-2014 10:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome