Sticking throttle - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-21-2012, 08:02 PM Thread Starter
Stromthusiast!
 
Mo Throttle's Avatar
 
Join Date: Sep 2008
Location: Clinton Twp. Mi
Posts: 87
Garage
Sticking throttle

I installed Oxford hot grips on the Glee. Then tried to install my Vista cruise universal throttle lock. The wide flange on the grip put the lock too far from the anchor point, so I tried to place the lock between the switch housing and the grip, i.e., directly on the throttle tube. Fine. When I'm finishing up and tightened the bar end, the throttle was sticking open and not snapping closed. There was no clamping pressure on the throttle from the lock. I'd loosen the bar end and it would snap closed. Tighten it and it sticks. It's a snug fit between the switch housing and the grip end. It's almost if when I tighten the bar end, it draws up the grip and pinches the grip. So I removed the VC. When I tightened the bar end the throttle still sticks open!! The bar end and throttle were fine until the Oxfords were installed. What have I done wrong? P.S. I also have OEM handguards. Any ideas??

Thanks, Mo

"There's a race of men that don't fit in,
A race that can't stand still;
So they break the hearts of kith and kin,
And they roam the world at will."...Robert Service
Mo Throttle is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-21-2012, 08:56 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Check the end of the grip and throttle tube nearest the bar end weight. You may need to open up the hole in the end of the grip or move the throttle housing to the left a little.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 4 Old 07-30-2012, 03:07 PM Thread Starter
Stromthusiast!
 
Mo Throttle's Avatar
 
Join Date: Sep 2008
Location: Clinton Twp. Mi
Posts: 87
Garage
I tried that. Nothing worked properly til I removed the vista cruise. AOK now. thanks Greywolf.

Thanks, Mo

"There's a race of men that don't fit in,
A race that can't stand still;
So they break the hearts of kith and kin,
And they roam the world at will."...Robert Service
Mo Throttle is offline  
 
post #4 of 4 Old 07-30-2012, 03:36 PM
Stromthusiast!
 
Join Date: Mar 2011
Location: Pasadna area
Posts: 13,600
When reinstalling my bar end I can cause the same problem with the throttle. It takes some adjustment to get it right and keep it free
notacop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome