speedometer stays at ZERO "0" - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-02-2012, 01:53 PM Thread Starter
Stromthusiast!
 
Join Date: Mar 2012
Location: Montreal
Posts: 17
speedometer stays at ZERO "0"

I was riding today and all of a sudden the digital speedometer started bouncing speeds up and down. Then remained at zero and hasn't budged since. Tried starting and restarting the bike to no avail ? Any idea what might of happened or what can fix it ?
Mtl-strom is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-02-2012, 01:56 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
A wiring connection could have come loose or something could have happened in the panel or at the sender near the front sprocket.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #3 of 7 Old 07-02-2012, 02:14 PM
Stromthusiast!
 
stromdon's Avatar
 
Join Date: Jun 2009
Location: Grants pass
Posts: 66
Garage
Under warranty

Quote:
Originally Posted by greywolf View Post
A wiring connection could have come loose or something could have happened in the panel or at the sender near the front sprocket.
I would'nt even mess with it,take it to your dealer,it's still under warranty...
stromdon is offline  
 
post #4 of 7 Old 07-02-2012, 04:02 PM Thread Starter
Stromthusiast!
 
Join Date: Mar 2012
Location: Montreal
Posts: 17
Tried again and still a permanent zero for speed. I'm not wiring savvy or confident enough to play around with this so the dealer it will be. Greywolf"s explanation does make sense though. Everything works except for the speed and odometer related stuff. Gear indicator, time and other electronics work. Just hope this wont cost $$$. Nothing major happened to provoke this.
Mtl-strom is offline  
post #5 of 7 Old 07-02-2012, 04:29 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
The bike is under warranty. It shouldn't cost anything.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #6 of 7 Old 07-02-2012, 04:41 PM
Stromthusiast!
 
BB63's Avatar
 
Join Date: Mar 2012
Location: Redcliffe QLD AUS
Posts: 387
Assuming it is the same or similar to the SV, it will be the ceremac speedo drive in the front hub has smashed, usually from a sloppy job on refitting the front wheel after a new tyre or such.
Cheers brian
BB63 is offline  
post #7 of 7 Old 07-02-2012, 04:48 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
The Glee speedo sensor is not on the front wheel. It's on the front sprocket shaft like the Vee.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome