Where is the fuse for my ABS system? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 1Likes
  • 1 Post By Spec
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-03-2019, 09:48 PM Thread Starter
Stromthusiast!
 
bajakirch's Avatar
 
Join Date: Nov 2016
Location: America's Dairyland
Posts: 495
Where is the fuse for my ABS system?

My ABS light began coming on intermittently a few weeks ago, and not it's constantly on. I know this means there's a problem with the ABS system and I'm hoping to do some trouble-shooting this weekend.

I'm hoping for an easy fix like a blown fuse -- can anyone advise where I can find my ABS system fuse?

If it's a good day to wash the bike, it's a better day to ride the bike.
bajakirch is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-05-2019, 04:17 PM
Stromthusiast!
 
Join Date: Mar 2017
Posts: 20
There are two fuses for the ABS system near the battery. Both have covers with "ABS" on them - One is 15A and one is 25A, I think. I don't believe any of the fuses in the actual fuse box relate to the ABS.
Dodobo is offline  
post #3 of 6 Old 07-05-2019, 07:23 PM
Stromthusiast!
 
Spec's Avatar
 
Join Date: Jun 2012
Location: Gateway to Death Valley
Posts: 3,439
Garage
Am intermittent problem isn't a fuse more like a loose connection.

Check the sensors at the hub rings. Take them off and clean the ends. Check the wires themselves for nicks or breaks. Follow the wires back to where they plug in to the harness. Check the connections on the ABS computer.
Gert likes this.
Spec is online now  
 
post #4 of 6 Old 07-06-2019, 06:43 PM
Stromthusiast!
 
Join Date: Dec 2015
Location: Cincinnati, OH
Posts: 51
Garage
Is the FI light coming on?

Got the heart attack over and done with - Prudhoe Bay or Bust!
slane6 is offline  
post #5 of 6 Old 07-07-2019, 12:29 PM Thread Starter
Stromthusiast!
 
bajakirch's Avatar
 
Join Date: Nov 2016
Location: America's Dairyland
Posts: 495
Quote:
Originally Posted by slane6 View Post
Is the FI light coming on?
Nope.

Had the light turning on and off intermittently earlier, now it's on full-time.

If it's a good day to wash the bike, it's a better day to ride the bike.
bajakirch is offline  
post #6 of 6 Old 07-08-2019, 10:56 PM
Stromthusiast!
Junior Trooper
 
wadestrom's Avatar
 
Join Date: Jun 2014
Location: prince george bc
Posts: 8
Mine comes on on my 2012 650 only in the rain. I have had a suzuki mechanic look and it is not producing a code. I suspect water is causing a poor electrical connection somewhere and causing the light. My signal lights also occasionally not work in the rain.

The headlights stopped during last summer after a rainy ride and was forced by chasing wiring harnesses and cleaning corrosion out of one of them.

I suspect the same issue from the signal lights and abs light

Sent from my SM-A520W using Tapatalk

2012 Glee, Givi E22n/Shad SH45 Topcase
wadestrom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome