Oil Consumption (burnt) - Page 4 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 28Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 34 Old 03-09-2019, 05:46 PM
$tromtrooper
 
itlives's Avatar
 
Join Date: Apr 2014
Location: Shreveport, LA
Posts: 50
On my post saying 130f across Death Valley, I was guessing . I did have my evaporative cooling jacket on and do not think I would have faired well without it. The irony is I was supposed to go to Redding and it was 112f that day! Wtf- I left Louisiana looking for lower temps!
itlives is offline  
Sponsored Links
Advertisement
 
post #32 of 34 Old 03-11-2019, 11:15 PM Thread Starter
Stromthusiast!
 
JonathanAU's Avatar
 
Join Date: Apr 2017
Location: Melbourne. Australia
Posts: 52
Quote:
Originally Posted by V-Harry View Post
Got thinking about no drain on air box and there has to be one.
See from manual.
Jonathon pull this plug and see if any oil present, worth a look.

Harry
that is good idea , if traces of oil are in there, the mystery is solved.
I have been checking the oil levels and it's been the same in last 2 weeks.

Also my best fuel consumption ever was in that trip where the oil disappeared.
JonathanAU is offline  
post #33 of 34 Old 03-11-2019, 11:20 PM Thread Starter
Stromthusiast!
 
JonathanAU's Avatar
 
Join Date: Apr 2017
Location: Melbourne. Australia
Posts: 52
Quote:
Originally Posted by V-Tom View Post
It hit 126F when I went through Death Valley in 2011 on my 2006 DL650. (Actual moving at speed temperature.)

..Tom
Quote:
Originally Posted by itlives View Post
On my post saying 130f across Death Valley, I was guessing . I did have my evaporative cooling jacket on and do not think I would have faired well without it. The irony is I was supposed to go to Redding and it was 112f that day! Wtf- I left Louisiana looking for lower temps!
Quote:
Originally Posted by ddphillips View Post
Rode a 2012 with 42,000kms from sydney to adelaide in 43c temps after buying it, no noticeable oil usage over 1,400kms. Same engine at 61,000kms no oil usage issues, you can buy that engine if you want- cheap too!

yeeeeh that's insanely hot, I think I like temps under 32 degrees C more. My top have been 39 - 40 C and I was not enjoying it so much. Although pour water over myself was satisfying , riding wet (dripping from heat to toe) was a new experience, valid if you have to ride in hot environments .
JonathanAU is offline  
 
post #34 of 34 Old 03-18-2019, 03:43 PM
Stromthusiast!
 
Join Date: Feb 2015
Location: Seattle
Posts: 158
My Triumph Sprint used a little oil. Triumph suggested that it was ok to burn some oil up to 1 quart / 1000 miles!
itlives and JonathanAU like this.

2013 DL650A, OEM centerstand, Powerlet outlet, Parabellum windshield with X-screen deflector.
scritch is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Consumption Problem?? big-w DL650A - 2012-2016 37 03-05-2015 10:42 AM
Fuel Consumption for a K2 Vee Cabbage Mechanic V-Strom Modifications and Performance 0 04-28-2012 08:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome