Wiring help!! - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 7Likes
  • 1 Post By p38arover
  • 4 Post By VstromGrin
  • 1 Post By p38arover
  • 1 Post By D.T.
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 10-14-2018, 10:29 PM Thread Starter
Stromthusiast!
 
VstromGrin's Avatar
 
Join Date: Oct 2015
Location: Ireland
Posts: 293
Wiring help!!

I was wiring in an additional led brake light, and I really shouldn't go near wiring connections cause I haven't got a clue about electrics but anyway, I decided to have a go,

(just noticed I didn't even spell wiring correctly in the thread title!!) [fixed - p38arover]

obviously I connected something wrong, I switched on the bike to see if the light was working, I think I could smell a slight burning smell, switched off immediately but obviously I've done some damage, anyone have any idea what I've done? I'm hoping and praying it's just a fuse somewhere,
I have undone any connections I made, the bike starts and I have headlights. high and low beams, but the dash is blank, I have no indicators brake lights or taillights, any ideas? thanks.

2013 SUZUKI DL650 AL2

Last edited by p38arover; 10-14-2018 at 10:50 PM.
VstromGrin is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-14-2018, 10:50 PM
Super Moderator
 
p38arover's Avatar
 
Join Date: Jan 2009
Location: Western Sydney, NSW, Australia
Posts: 4,481
I haven't got the circuit diagram for your model in front of me but the first thing to check are the fuses. Fuse 5 on older models feeds the Orange Green wire to the brake lights, indicators, and dash.
VstromGrin likes this.

Ron B. VK2OTC
2007 Yamaha XJR1300

RIP Bucko
1979-2008 - Riding on forever

Last edited by p38arover; 10-14-2018 at 10:56 PM.
p38arover is offline  
post #3 of 6 Old 10-14-2018, 10:58 PM Thread Starter
Stromthusiast!
 
VstromGrin's Avatar
 
Join Date: Oct 2015
Location: Ireland
Posts: 293
Thanks just been searching on google and come across an old thread on advrider, guy says he had a short in the system that kept blowing the turn signal fuse which caused the loss of gauges, signal and brake and tail lights so I'll go and check the turn signal fuse now. hopefully I just shorted it out when I was trying to connect the extra brake light.

2013 SUZUKI DL650 AL2
VstromGrin is offline  
 
post #4 of 6 Old 10-14-2018, 11:20 PM Thread Starter
Stromthusiast!
 
VstromGrin's Avatar
 
Join Date: Oct 2015
Location: Ireland
Posts: 293
Problem solved buddy and thanks for your help, it was the 15 amp turn signal fuse, replaced it with the spare 15 amp they provide and everything is working again thank God, that's the last time I'm connecting anything electrical,
I'll get a buddy that's good at wiring to do the electrical hook up, good to know this though in case that fuse ever blows while away on a trip say, must get some spare fuses tomorrow to keep in the tool kit and replace that spare one in the fuse box. panic over in record time!!

Thanks p38arover for correcting my thread title typo too.
p38arover, Gert, wingstrom and 1 others like this.

2013 SUZUKI DL650 AL2

Last edited by VstromGrin; 10-14-2018 at 11:23 PM.
VstromGrin is offline  
post #5 of 6 Old 10-15-2018, 01:12 AM
Super Moderator
 
p38arover's Avatar
 
Join Date: Jan 2009
Location: Western Sydney, NSW, Australia
Posts: 4,481
Glad you got it sorted.
VstromGrin likes this.

Ron B. VK2OTC
2007 Yamaha XJR1300

RIP Bucko
1979-2008 - Riding on forever
p38arover is offline  
post #6 of 6 Old 10-15-2018, 08:40 AM
Stromthusiast!
 
D.T.'s Avatar
 
Join Date: Jul 2006
Location: Moneyapolis, MN
Posts: 1,953
You just need to study electricity more. I started out as a nOOb too and now I really like those type of problems.

You Tube is my favorite! Lots of help on YT.
VstromGrin likes this.

2012 Suzuki DL650AL2, over 45k miles already!
D.T. is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail light, brake and rear turn signal wiring Stoopy DL1000A - 2014-2016 35 09-11-2015 11:30 PM
Wiring the Bestem 929 with LEDS to EB: walk-through MrNobody Maintenance, Tech and Products. 9 04-22-2013 10:41 AM
2011 Wiring Harness Plugs, What Manufacture trainman General V-Strom Discussion 3 11-12-2012 11:40 PM
Plug for Easternbeaver wiring harnesses smarc1214 Maintenance, Tech and Products. 15 07-04-2010 12:39 PM
Warning re brake wiring fault & fuses blowing !! colin.stuart V-Strom Service and Maintenance Questions and Discussions 4 04-07-2010 05:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome