Hazard signals not working - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-15-2018, 09:56 AM Thread Starter
Stromthusiast!
 
bajakirch's Avatar
 
Join Date: Nov 2016
Location: America's Dairyland
Posts: 495
Hazard signals not working

I noticed the other day my hazard signals don't appear to be working. Turn signals are OK, so I'm thinking something with the switch.

Any common things I should look for?

If it's a good day to wash the bike, it's a better day to ride the bike.
bajakirch is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-15-2018, 10:14 AM
Stromthusiast!
 
Join Date: Feb 2015
Location: Amsterdam
Posts: 408
If the turn signals work but the hazards don't, then I would start with the contacts within the handlebar cluster. That's the only place where the hazards and turn signals don't share the same wiring/relays/light bulbs and whatnot. (Or do they diverge as well in the contact switch, to allow you to use the hazards in Park?)

Has the bike been exposed to a lot of rain lately? The hazards switch is a lot more exposed than the turn signal switch.

Last edited by BackPacker; 09-15-2018 at 10:19 AM.
BackPacker is offline  
post #3 of 5 Old 09-15-2018, 10:14 AM
Super Moderator
 
Brockie's Avatar
 
Join Date: Jul 2013
Location: Gatton, Queensland, Australia
Posts: 4,450
Garage
I'd start inside the LH switch block, checking the wires and contacts in there.

2010 Weestrom; 2017 Kawasaki Versys-X300; 1988 Suzuki GSXR1100
Brockie is online now  
 
post #4 of 5 Old 09-16-2018, 09:44 AM Thread Starter
Stromthusiast!
 
bajakirch's Avatar
 
Join Date: Nov 2016
Location: America's Dairyland
Posts: 495
Quote:
Has the bike been exposed to a lot of rain lately? The hazards switch is a lot more exposed than the turn signal switch.
In fact, yes. I ended up caught up in a major storm about a month ago and rode in downpour conditions for about 2 hours.

I'll check the contacts.

If it's a good day to wash the bike, it's a better day to ride the bike.
bajakirch is offline  
post #5 of 5 Old 09-16-2018, 05:58 PM
Stromthusiast!
 
Join Date: Jun 2012
Location: UK
Posts: 31
Mine sometimes does this. I've found toggling tge switch a few tines then riding with the hazards turned on eventually brings them back to life. I've previously taken the left hand switch apart expecting corrosion or something but found nothing in there (still sprayed contact cleaner on there whilst I had it apart).
uk-vstrom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacement turn signals for 1st-gen Vee? bwringer DL1000 from 2002-2012 11 09-20-2017 07:06 PM
Bestem T-Box lighting. Turn and brake signals... FredBGG General V-Strom Discussion 5 02-02-2015 11:32 AM
Turn signals not working? domromer General V-Strom Discussion 10 07-11-2012 09:00 PM
Weak turn signals on the V-Strom in daylight Mercenary General V-Strom Discussion 18 07-16-2009 07:57 PM
Protected front turn signals barker Maintenance, Tech and Products. 14 07-06-2009 09:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome