Weird LED headlight problem - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-09-2018, 09:43 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: May 2016
Posts: 1
Weird LED headlight problem

Put in a new set of LED headlights.

When you first turn on the key, the lights start on low beams.

When you hit the high beam switch, they come up fine.

BUT...they won't turn back down to low with the switch.

If you turn off the key, they will restart on low, BUT same as above.

Any ideas?? Thanks!
BradB is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-09-2018, 10:29 PM
Stromthusiast!
 
Brojon's Avatar
 
Join Date: Apr 2016
Location: Great State of Texas
Posts: 844
Did you wire through a harness? If so double check the wiring.
Sounds like the relay is getting voltage feed back to the coil keeping it energized.

"The further a society drifts from truth, the more it will hate those who speak it."
George Orwell

2015 DL650
Brojon is offline  
post #3 of 3 Old 05-12-2018, 10:26 PM
Stromthusiast!
 
Join Date: Mar 2011
Location: Pasadna area
Posts: 13,558
I have the EB headlight harness and when I put in the LEDs all worked just like before.
Mine's an 04 so maybe some wiring differences?
notacop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome