What is this part? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012-2016 DL650A 2012-2016 (L2-L6)

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 11-10-2013, 03:07 PM Thread Starter
Stromthusiast!
 
WeePilot's Avatar
 
Join Date: Mar 2013
Location: Loomis, CA
Posts: 151
What is this part?

What are the parts pictured below and how do I get the rust off of them? It's the cylinder shape with the silver color metal on each end.

ImageUploadedByMO Free1384113877.066601.jpg






Sent from Motorcycle.com Free App
Attached Images
File Type: jpg ImageUploadedByMO Free1384113933.348867.jpg (31.2 KB, 117 views)
WeePilot is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-10-2013, 04:22 PM
Stromthusiast!
 
D.T.'s Avatar
 
Join Date: Jul 2006
Location: Moneyapolis, MN
Posts: 1,998
That's the ignition coil. Not sure why it's rusty...


Steel wool should get it off or a wire brush.

2012 Suzuki DL650AL2, over 45k miles already!
D.T. is offline  
post #3 of 11 Old 11-10-2013, 04:23 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Those are your ignition coils. You basically leave them alone. I've never heard of a coil failure due to rust on the iron plates. They just strengthen the magnetic field.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
 
post #4 of 11 Old 11-11-2013, 08:13 AM Thread Starter
Stromthusiast!
 
WeePilot's Avatar
 
Join Date: Mar 2013
Location: Loomis, CA
Posts: 151
Has anyone else had a rust problem like this?


Sent from Motorcycle.com Free App
WeePilot is offline  
post #5 of 11 Old 11-11-2013, 08:31 AM
$tromtrooper
 
chicago's Avatar
 
Join Date: Oct 2009
Location: bishop, CA
Posts: 3,362
Quote:
Originally Posted by WeePilot View Post
Has anyone else had a rust problem like this?


Sent from Motorcycle.com Free App


Looks just like mine.
chicago is offline  
post #6 of 11 Old 11-11-2013, 08:35 AM
$tromtrooper
 
Kenscoots's Avatar
 
Join Date: Mar 2013
Location: Long Island City, NY
Posts: 17
Quote:
Originally Posted by chicago View Post
Looks just like mine.
Just like mine too.
Kenscoots is offline  
post #7 of 11 Old 11-11-2013, 10:42 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
I think you'll find just about everybody's looks like that.


Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #8 of 11 Old 11-12-2013, 03:33 PM
Stromthusiast!
 
Join Date: Mar 2009
Location: Canton, Ga
Posts: 29
Just went and looked, mine are the same.
ronhawk62 is offline  
post #9 of 11 Old 11-12-2013, 04:17 PM
Stromthusiast!
 
1 Wheel Drive's Avatar
 
Join Date: Oct 2010
Location: Southern NH
Posts: 468
It's rusty because these coils are wound around a laminated iron core and the manufacturer did not bother to paint or otherwise protect it from rusting. It does not affect it's ability to generate a spark, but if the rust offends you, you could coat the rusty core with some sort of paint. Just be sure that that the mounting / contact area is left bare as I believe it is a frame grounding point for the coil.
1 Wheel Drive is offline  
post #10 of 11 Old 11-13-2013, 12:44 AM
Stromthusiast!
 
MeefZah's Avatar
 
Join Date: Nov 2006
Location: Eureka, Calif
Posts: 2,980
Quote:
Originally Posted by WeePilot View Post
Has anyone else had a rust problem like this?


Sent from Motorcycle.com Free App
Normal.

.
MeefZah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome