Engine knock - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650 and DL650A - 2004 to 2011 DL650 from 2004-2006 (K4-K6) and DL650 or DL650A from 2007-2011 (K7-L1)

 2Likes
  • 2 Post By blaustrom
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-05-2019, 01:22 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Aug 2019
Posts: 2
Engine knock

I have a 08 650dl which I have loved now recently I have had my engine seals replaced and my son was riding it down the interstate and just powered down and died on him. I brought it to a shop and now they are telling me the lower half has an engine knock and said I need to take it to a Suzuki dealer for proper diagnosis. I have about 70k on it and have loved it. So has anyone else experienced this or have any idea what's wrong with it?
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-05-2019, 03:59 PM
Stromthusiast!
Super Trooper!
 
blaustrom's Avatar
 
Join Date: Apr 2008
Location: north east, Buffalo NY area
Posts: 2,653
Quote:
Originally Posted by [email protected] View Post
...had my engine seals replaced .
What seals were replaced?

Are you sure your engine did not run out of oil?

We need more details to be able to help I think.

And WELCOME to the forum. Fill in your info so we know where you are, what you have etc.
Big B and richlandrick like this.

....
Blau1 2004 DL650-sold
Blau2 2014 DL1000A
blaustrom is online now  
post #3 of 5 Old 09-05-2019, 07:08 PM
Stromthusiast!
Super Trooper!
 
Join Date: Mar 2011
Location: Pasadna area
Posts: 13,987
Wow, condolences. Hate to hear, I just fixed my bike and now it won't run". At 70k were the seals leaking?
Who did the seals? hate to suggest they just hosed you.
notacop is online now  
 
post #4 of 5 Old 09-09-2019, 06:11 PM
Stromthusiast!
 
Join Date: Sep 2014
Location: Midwest snow country
Posts: 482
I've been on this forum a long time and I've never heard of bad engine seals in a Wee; at any mileage. As far as knocking, the v twin sounds like it making a lot of noise even when everything is fine. I'm hoping for the best for you.
Wee Willy Winky is offline  
post #5 of 5 Old 09-09-2019, 07:25 PM
Stromtrooper.com Sponsor
 
richlandrick's Avatar
 
Join Date: Oct 2007
Location: Clover, S.C.
Posts: 4,534
I've been on the V-Strom forums for 14 years. Never heard of a seal going bad.

Need more info.
richlandrick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome