New LED headlights + EB relay = High Beams Only? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650 and DL650A - 2004 to 2011 DL650 from 2004-2006 (K4-K6) and DL650 or DL650A from 2007-2011 (K7-L1)

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 01-20-2019, 09:32 PM Thread Starter
Stromthusiast!
 
Join Date: May 2011
Location: Columbia, MO
Posts: 56
New LED headlights + EB relay = High Beams Only?

Looking for help doing some troubleshooting.

Just installed a new set of Beamtech LED headlights. I'd previously had the Eastern Beaver relay installed too.

The issue: with both LED bulbs installed I only get High beams no matter what position the switch is in.

With only one LED installed the switch/bulbs work just fine.

Thoughts?
Chefdave is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-20-2019, 09:37 PM
Stromthusiast!
 
Join Date: Mar 2011
Location: Pasadna area
Posts: 12,787
I'd say you goofed something. I installed the EB cabling and later added LED's and no problem with the end result. Low and high beam work as designed.
notacop is offline  
post #3 of 7 Old 01-20-2019, 09:45 PM Thread Starter
Stromthusiast!
 
Join Date: May 2011
Location: Columbia, MO
Posts: 56
Bulbs have both high and low LED's.

You can switch between high/low just fine with only 1 bulb installed.
Chefdave is offline  
 
post #4 of 7 Old 01-20-2019, 10:14 PM
Stromthusiast!
 
Warhead's Avatar
 
Join Date: Sep 2018
Location: Canada, ON
Posts: 47
Garage
Have you tried one LED at a time in both position (left then right)

Don't drop your bike after owning it for 3 hours.
Warhead is offline  
post #5 of 7 Old 01-20-2019, 10:52 PM
Super Moderator
 
Brockie's Avatar
 
Join Date: Jul 2013
Location: Gatton, Queensland, Australia
Posts: 3,996
Garage
I am assuming that you have a Wee1 or Wee2 and guessing that your wiring from the EB relay is wrong.
You could confirm this by reverting to OEM headlight wiring. I have LED's in my Wee1 with no relay. Simple plug'n'play.

2010 Weestrom; 2017 Kawasaki Versys-X300; 1988 Suzuki GSXR1100
Brockie is offline  
post #6 of 7 Old 01-22-2019, 06:11 PM
Stromthusiast!
 
Rolex's Avatar
 
Join Date: Feb 2013
Location: Sydney's East
Posts: 2,532
LED's are polarity sensitive unlike normal globes, so + must run to + and - to -.

Do you get the same result with one incandescent globe and one LED ?


Use a meter and probe the back of the globes to ensure the current is flowing in the right direction when the switch is being manipulated.

Some of the 19 rides in my shed
2014 V2, Snoopy
2009 Wee, Pumbaa the pig
WR450F, The Blue Postie Bike
YZ250N smoker with rego, Stinky.
Yamaha MT09 (FZ09), The Scud missile.
Club Lead not Club Med.
He with the most toys wins.
Out of my depth in a puddle.
Live life on the edge you will see more that way.
Ridding a motorcycle keeps things in balance.
At the end of each trail and at the end of each day history is made.
Rolex is offline  
post #7 of 7 Old 04-16-2019, 05:34 PM
Stromthusiast!
 
Join Date: Mar 2017
Location: Royal Oak, MI
Posts: 39
Garage
Also interested to hear about this. I have the EB with single relay cutout and thinking about a headlight upgrade

2009 Wee-Strom. Center Stand, Givi crash bars, AMS skid plate, MadStad wind screen mount, Cee Baily Windscreen, voltmeter, fork mount fog lights, Shinko 804/805, seat concepts saddle, EB PC8,heated grips, single headlight cutout, dual USB charger, 12v charger. Next mods: sonic springs, short blinkers, bark busters, delkevic exhaust.
StromRider30 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash to Pass & Headlight Relay Kit gdrew DL650 and DL650A - 2004 to 2011 24 04-04-2018 11:58 AM
Yelled at for high beams, but they weren't on SteveFoy DL650A - 2012-2016 20 06-14-2017 12:15 PM
High beams and the blue indicator light Aka DL650A - 2012-2016 21 07-09-2013 04:28 PM
Electronic Help - burnt wire! EB headlight relay and EB fuse box Photoryder Maintenance, Tech and Products. 18 04-23-2013 08:34 PM
high beams not working dphares DL1000 from 2002-2012 8 04-01-2013 08:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome