07 DL650 Stalling - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650 and DL650A - 2004 to 2011 DL650 from 2004-2006 (K4-K6) and DL650 or DL650A from 2007-2011 (K7-L1)

 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 Old 11-19-2018, 04:12 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Mar 2018
Location: South Central Kansas
Posts: 5
07 DL650 Stalling

I am having a problem with randomly pulling up to stop signs and my bike stalling. I have checked and cleaned the clutch switch. I have replaced the vacuum covers on the throttle body. I have cleaned the air filter. Check the spark plugs and installed a volt meter to monitor the battery and charging system. The last time it did it I noticed that my voltage dropped low 11.8v when it happened, normal idle is around 14.4v and bike turned off it is 12.3v. Not sure if this is a symptom or a cause. This has been over multiple tanks of gas, though I do have the rubber gasket for the gas cap on order because it is cracked and brittle. This next tank I am going to run some injector cleaner through. The bike has just over 26k miles on it. Any suggestions on what to be checking next?
Wezitar is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 11-19-2018, 06:09 PM
Super Moderator
 
Big B's Avatar
 
Join Date: May 2005
Location: Central OHIO "Go Buckeyes"
Posts: 16,718
Garage
I'd replace the battery IMHO, they can do so very strange things......go with YUASA. If that still isn't the issue, sounds like a TB balance is in order........

BRIAN "GO Buckeyes, GO Wildcats"!

2015 DL650 XT "Hector"

1997 Honda Valkyrie 1500 custom “Dolores”




Big B is offline  
post #3 of 16 Old 11-19-2018, 08:17 PM
Stromthusiast!
Super Trooper!
 
blaustrom's Avatar
 
Join Date: Apr 2008
Location: north east, Buffalo NY area
Posts: 2,654
The low voltage is a concern. Get the battery checked at an auto parts store. If the battery tests good, make sure battery contacts and main ground contact are good, clean and tight.

You also may want to check the main connector on the left side of the cowling, although I don't think that's the problem.

Did you ever sync the throttles?

…....
Blau1 2004 DL650-sold
Blau2 2014 DL1000A
blaustrom is online now  
 
post #4 of 16 Old 11-19-2018, 08:19 PM
Super Moderator
 
Big B's Avatar
 
Join Date: May 2005
Location: Central OHIO "Go Buckeyes"
Posts: 16,718
Garage
Batteries can test good and still be bad.
K9 Wee likes this.

BRIAN "GO Buckeyes, GO Wildcats"!

2015 DL650 XT "Hector"

1997 Honda Valkyrie 1500 custom “Dolores”




Big B is offline  
post #5 of 16 Old 11-19-2018, 09:40 PM
Stromthusiast!
 
dmfdmf's Avatar
 
Join Date: Nov 2012
Location: California
Posts: 805
Stalling coming to a stop is a common symptom of a bad TPS (throttle position sensor) but I'd rule out other items first because it would be unusual (but not unheard of) for the TPS to fail at only 26K miles. The TPS on my K7 Wee went bad at 85K miles which is more typical.
HokiesRWee and Gert like this.

Pink Floyd: And did you exchange a walk-on part in the war for a lead role in a cage?
---------------------------------------------------------------------------------------------
Current: 2014 V-Strom DL650 ABS Red
Next Up: ?
Past: Suzuki: DL650AK7, GS400; Honda: CB125, Express 49cc
dmfdmf is offline  
post #6 of 16 Old 11-20-2018, 06:51 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Mar 2018
Location: South Central Kansas
Posts: 5
Battery tested fine at the auto store. I have not synced the throttle bodies. Maybe that is the next step. Both of the terminals are clean on the battery. Where is the main ground on the bike?
Wezitar is offline  
post #7 of 16 Old 11-21-2018, 12:40 AM
Stromthusiast!
Super Trooper!
 
blaustrom's Avatar
 
Join Date: Apr 2008
Location: north east, Buffalo NY area
Posts: 2,654
Quote:
Originally Posted by Wezitar View Post
... Where is the main ground on the bike?
Follow the black (negative) cable going from the battery to the engine. And I think you may have a secondary smaller gauge wire going to the fuse terminal??

…....
Blau1 2004 DL650-sold
Blau2 2014 DL1000A
blaustrom is online now  
post #8 of 16 Old 11-21-2018, 09:02 AM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Mar 2018
Location: South Central Kansas
Posts: 5
So I am thinking it is the TPS. This morning on my commute it died on me at the second stop sign about 4 miles in fully warmed up. Started it up again 2 miles later at the next stop sign I watched the idle speed bounce around and slowly creep up with out me touching the throttle. By the time i got to work it wouldn't idle down past 2.5k even after blipping the throttle get get some higher RPMs.
Wezitar is offline  
post #9 of 16 Old 11-21-2018, 09:24 AM Thread Starter
Stromthusiast!
Junior Trooper
 
Join Date: Mar 2018
Location: South Central Kansas
Posts: 5
I am going to try this procedure and see if it fixes anything or give an error code
Another procedure is the preset idle speed reset.

1) Turn the ignition switch to the OFF position.
2) Remove the seat.
3) Put the bike in dealer mode.
4) Turn the ignition switch to the ON position.
5) Turn the ignition switch to the OFF position.
6) Then, wait more than 5 seconds.
The ISC valve automatically is set at the PRE-SET position.
7) Take the bike out of dealer mode.
Wezitar is offline  
post #10 of 16 Old 11-22-2018, 03:02 AM
Stromthusiast!
 
Rug Emporium's Avatar
 
Join Date: Oct 2009
Location: Lynnwood, Washington
Posts: 13
Garage
I had to replace the TPS on my K7 several years ago, I don't remember how many miles but it was probably around the same mileage. Be sure to get the newer part and not the original part or you'll likely just have to replace it again.
HokiesRWee likes this.

Hi
Rug Emporium is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I suspect the DL650 is better off-road than advertised. DaisyCutter DL650A - 2012-2016 35 06-18-2019 02:23 PM
Fall Farkling For the DL650 and DL1000 Vstrom Models SV Racing Parts SV Racing Parts 0 11-07-2017 01:07 PM
DL650 fork swap with a Multistrada?? visovm Suspension and Tire Tech 14 12-08-2015 04:25 PM
2012 DL650 Elka Custom Built Hand Assembled Shocks Now Shipping SV Racing Parts SV Racing Parts 15 03-15-2013 09:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome