Suzuki LED Indicators, Relay Died, warning - relay location - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000A - 2017+ DL1000A - 2017 (L7) and later

 2Likes
  • 2 Post By bosnjo
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-05-2018, 04:41 PM Thread Starter
Stromthusiast!
 
bosnjo's Avatar
 
Join Date: Dec 2013
Location: Portugal
Posts: 954
Suzuki LED Indicators, Relay Died, warning - relay location

I have 2017 model DL1000 but used LED indicators, Suzuki OEM kit, that I removed from my previous 2014 DL1000. So, the kit is something like 3 years old. Today, I noticed first I lost all indicators. The switch would do nothing. Then a bit later, they would turn on but not flash. I tried left, right, hazard... All the same, just turned on without flashing. As I was on my way to the dealer for something different, I told him about the problem. Well, the bike is under warranty but the indicators kit is not. So, he handed me cheap chinese relay for LED indicators and let me use his tools and elevator.
I did all the job by myself, and let me tell you, you have to remove almost all bits and pieces under the seat to get to the relay. It is not on the same location as it was on 2014 DL1000, it's burried deep down. After half an hour, the job was done and I had my indicators working with cheap chinese relay. The dealer charged me nothing. He knows I can work well on the bike and it was not the first time he lets me use his shop and tools and charges me nothing.
At least I have my indicators back.
But, he looked closely at what I was doing and said it didn't make sense the position of the relay because it picks a lot of heat straight from the engine. He said the location of the relay on previous model was under the seat so it didn't get any heat from the engine. He said if it happens again, I should relocate the relay to the location where it was on previous model and see if it makes any difference.
Currenv and StromHK like this.

2017 DL1000 White
2014 DL1000 Red (sold)
2012 DL650 White (sold)
bosnjo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome