Bike won't start, fuel pump not pumping - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000A - 2014-2016 DL1000A - 2014-2016 (L4-L6)

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 Old 04-09-2016, 12:44 PM Thread Starter
Stromthusiast!
 
Join Date: Nov 2014
Location: South Carolina
Posts: 18
Bike won't start, fuel pump not pumping

Got my bike back from the dealership for the recent recalls. Was riding it the other day and it shut off going down the road and wouldn't start again. Says "chec" on the display, and I noticed the fuel pump isn't making any noise when I turn on the switch. Any ideas? I just checked the connector to the fuel pump and changed out the fuse, no luck there. 2014 DL 1000A.
jacej86 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 04-09-2016, 12:46 PM
Stromthusiast!
 
Vdubfreak67's Avatar
 
Join Date: Feb 2016
Location: Florence ky
Posts: 207
What recall? If they pulled the tank off you very well could have a loose wire. Happened to me.


Sent from my iPhone using Tapatalk
Vdubfreak67 is offline  
post #3 of 23 Old 04-09-2016, 12:49 PM Thread Starter
Stromthusiast!
 
Join Date: Nov 2014
Location: South Carolina
Posts: 18
I don't remember exactly, I know it was three separate recalls, and at least one of them required the tank to be removed.
jacej86 is offline  
 
post #4 of 23 Old 04-09-2016, 12:56 PM
Super Moderator
 
V-Tom's Avatar
 
Join Date: Jul 2006
Location: Port Perry, Ontario, Canada
Posts: 12,772
Check the dumb things first... is the kill switch on? Was the side-stand up in gear?


..Tom

2006 DL650: 202,000 km 125,500 miles, Sold
2012 DL650 139,500+ km, 86,700+ miles. Sold
2015 DL1000 New July 2015 200,000+ km, 125,000 miles.

This can help preventing from cars pulling out in front of you (SMIDSY)
SMIDSY detailed report.


V-Tom is offline  
post #5 of 23 Old 04-09-2016, 12:59 PM Thread Starter
Stromthusiast!
 
Join Date: Nov 2014
Location: South Carolina
Posts: 18
Bike in neutral, tried both kick stand up and down. No dice.

Vdub, what connector was loose in your case?
jacej86 is offline  
post #6 of 23 Old 04-09-2016, 01:06 PM
$tromtrooper
 
VSrider's Avatar
 
Join Date: Jul 2012
Location: Virginia Beach, Va. USA
Posts: 1,906
A blown main fuse will cause a "chec" also.

VSrider is offline  
post #7 of 23 Old 04-09-2016, 01:21 PM Thread Starter
Stromthusiast!
 
Join Date: Nov 2014
Location: South Carolina
Posts: 18
I just tried to main 30A fuse idea, checked it, look fine, then replaced it with the spare for good measure. Still says "chec" and won't start.
jacej86 is offline  
post #8 of 23 Old 04-09-2016, 01:26 PM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Not the main fuse but the ignition fuse may be blown. That and the kill switch, side stand switch and the wiring for them are the usual suspects. They will cause a CHEC and prevent the fuel pump from running.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informa...-you-have.html
greywolf is offline  
post #9 of 23 Old 04-09-2016, 05:59 PM Thread Starter
Stromthusiast!
 
Join Date: Nov 2014
Location: South Carolina
Posts: 18
Checked and changed all the fuses, no luck there. I guess it's time to break out the multimeter...
jacej86 is offline  
post #10 of 23 Old 04-09-2016, 07:47 PM
Stromthusiast!
 
York's Avatar
 
Join Date: Feb 2015
Location: Texas
Posts: 166
"FI"

Jacej86, I get the CHECK in the display when the kill switch is off. At the same time the gear indicator will only show "-".

However - the red FI indicator (11) will stay on when turning the ignition on until the odometer/trip (20) comes up. After that the FI indicator will TURN OFF.
What is your display doing?







Check the NOTICE and NOTE on page 2-13 of the manual



jacej86 likes this.

Ride - Life Is Too Short!
York
York is offline  
Sponsored Links
Advertisement
 
Reply

Tags
2014 dl1000 adv , fuel pump , issue , recall , won't start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome