Givi Trekker Outback Mounting Hardware? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000A - 2014-2016 DL1000A - 2014-2016 (L4-L6)

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 01-23-2016, 01:30 PM Thread Starter
$tromtrooper
 
Join Date: Mar 2008
Location: NYC & FL
Posts: 258
Givi Trekker Outback Mounting Hardware?

After a bit more than a month, I've finally received part that was missing from my Givi top-case rack kit (SRA3105). I've already got the PL3105CAM racks mounted for the Trekker Outback side cases.

The top case mount shares one mounting location with the side rack kit (green arrows below). Unless I'm missing something obvious, it seems that the M6 flange-head bolts included with both mounting kits are too short. The bolt that comes with the side rack kit is M6x40. The bolt that comes with the top rack kit is M6x35. It looks like a M6x50, or longer, is required to pass through both the side case bracket and the top case bracket.

Anyone else run into this?

Tipsy

Lower Bolt 3 in this diagram has to pass through the bracket pictured in the second diagram below (Part 3), taking the place of Bolt 5 and Spacer 10 in that diagram.


Neither Bolt 3 or Bolt 5 are long enough to engage Nut 9

Last edited by TipsyMcStagger; 01-31-2016 at 01:45 PM.
TipsyMcStagger is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-23-2016, 03:50 PM Thread Starter
$tromtrooper
 
Join Date: Mar 2008
Location: NYC & FL
Posts: 258
For the sake of anyone who runs into this issue later on, it looks like an M60x60 is what's needed. M6x50 was the longest flange-head M6 bolt at my local hardware store and it's too short to fully engage the nylock with the #11 spacer in place.

I'll have to order an M6x60 flange-head from Fastenal on Monday.

Tipsy
TipsyMcStagger is offline  
post #3 of 11 Old 01-24-2016, 01:40 AM
Stromthusiast!
 
Join Date: Aug 2008
Location: Southwest VA
Posts: 122
What purpose does the #11 spacer serve? Would either of the shorter bolts work without that spacer in place?
blz2dwl is offline  
 
post #4 of 11 Old 01-24-2016, 09:46 AM Thread Starter
$tromtrooper
 
Join Date: Mar 2008
Location: NYC & FL
Posts: 258
Quote:
Originally Posted by blz2dwl View Post
What purpose does the #11 spacer serve? Would either of the shorter bolts work without that spacer in place?
I had the same thought. I'm not entirely sure why the spacer is there. But even without it, the two included bolts are too short. An M6x50 is long enough if the spacer isn't used.

Tipsy
TipsyMcStagger is offline  
post #5 of 11 Old 01-24-2016, 11:25 AM
Stromthusiast!
 
Vstrom N Me's Avatar
 
Join Date: Oct 2013
Location: Chicago Area
Posts: 267
I had the same problem with mine. My hardware store had them and I used a few washers to solve the problem.

Very nice panniers and I added a small LED in each one too
Vstrom N Me is offline  
post #6 of 11 Old 01-24-2016, 12:17 PM
Stromthusiast!
 
Bugzy's Avatar
 
Join Date: May 2011
Posts: 4,154
I had a longer set of bolts included in my kit to replace #5 when both the Givi side rack and Givi top plate were mounted together. I think it came with the side rack setup. Are you sure you don't have a longer set of screws extra at the end?

It was a while ago now so I don't remember specifics but I was able to get mine installed without buying anything. That #5 bolt is seemingly impossible to tighten up too. No space underneath to get a wrench in there.

Did you drill out the holes in the plastic to allow the spacer to fully seat? Maybe that is your issue?
Bugzy is offline  
post #7 of 11 Old 01-24-2016, 12:35 PM
Stromthusiast!
 
NSdave's Avatar
 
Join Date: Jan 2012
Location: Nova Scotia
Posts: 587
Quote:
Originally Posted by BugMagnet View Post
I had a longer set of bolts included in my kit to replace #5 when both the Givi side rack and Givi top plate were mounted together. I think it came with the side rack setup. Are you sure you don't have a longer set of screws extra at the end?



It was a while ago now so I don't remember specifics but I was able to get mine installed without buying anything. That #5 bolt is seemingly impossible to tighten up too. No space underneath to get a wrench in there.



Did you drill out the holes in the plastic to allow the spacer to fully seat? Maybe that is your issue?

Mine had the same.

they came with the side case racks. the instructions say to use the shorter bolts with only the side cases and to use the longer with the optional top case mount

I think I have them in a bag somewhere. lol

14' DL1000
NSdave is offline  
post #8 of 11 Old 01-24-2016, 12:45 PM Thread Starter
$tromtrooper
 
Join Date: Mar 2008
Location: NYC & FL
Posts: 258
Quote:
Originally Posted by BugMagnet View Post
I had a longer set of bolts included in my kit to replace #5 when both the Givi side rack and Givi top plate were mounted together. I think it came with the side rack setup. Are you sure you don't have a longer set of screws extra at the end?
Yep, there were no longer-bolts included in either kit.

Quote:
Originally Posted by BugMagnet View Post
It was a while ago now so I don't remember specifics but I was able to get mine installed without buying anything. That #5 bolt is seemingly impossible to tighten up too. No space underneath to get a wrench in there.
It's tight but if you have a ratcheting box wrench, you can tighten it.

Quote:
Originally Posted by BugMagnet View Post
Did you drill out the holes in the plastic to allow the spacer to fully seat? Maybe that is your issue?
I enlarged the holes in the plastic when I installed the side racks. I commented on it in this post and this post when I installed the racks.

Tipsy
TipsyMcStagger is offline  
post #9 of 11 Old 01-24-2016, 01:12 PM Thread Starter
$tromtrooper
 
Join Date: Mar 2008
Location: NYC & FL
Posts: 258
Interesting. I did some digging and found this set of installation instructions online which does in fact show a screw and washer to be used when installing the side racks with the top rack. I found my spare parts bag which I labeled "Parts removed when installing PL3105CAM racks." It has all of the removed stock hardware and lo and behold, the two washers, but not the two screws.

Interestingly enough, I have another saved set of PL3105CAM .pdf instructions I downloaded from somewhere, which makes no mention at all of installing the side racks with the top rack kit.

I wouldn't put it past Givi to have omitted these screws in error. My top rack installation kit was missing a component and instead had two copies of a part, only one of which was required. But they didn't forget to include the piece of paper that said "Quality Inspected by #52."

Tipsy

EDIT: Just found a link to the .pdf set of PL3105CAM instructions that make no mention of the SRA3105 top rack and does not include the longer screws and washers in the parts list. It's an older revision.

Last edited by TipsyMcStagger; 01-24-2016 at 02:24 PM.
TipsyMcStagger is offline  
post #10 of 11 Old 01-31-2016, 11:20 AM
Stromthusiast!
 
Join Date: Aug 2008
Location: Southwest VA
Posts: 122
Yeah, you must have gotten an early set. I just received and installed a set of these I got from Motostorm.it and the instuctions had a specific diagram dedicated to users installed the top and side racks together, and a longer bolt and washer set for that position.
blz2dwl is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome