FI light - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000A - 2014-2016 DL1000A - 2014-2016 (L4-L6)

 2Likes
  • 1 Post By mr_anonymous
  • 1 Post By 2stroke
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-10-2015, 09:40 AM Thread Starter
Stromthusiast!
 
Join Date: Jun 2015
Posts: 529
FI light

My bike has had the FI light come on twice. It would go off if turned ignition off and back on.
Brought it to my dealer, and they read the ECU error code. It said it was a exhaust butterfly issue. Cables needed to be adjusted. They told me that it's not under warranty, and that it was routine maintenance on this bike.
Sounded fishy to me, so I looked in the manual under maitanece schedule, and there was nothing about adjustments to exhaust butterflies.
Think I'm going to call Suzuki. Anyone else had this issue?
2stroke is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-10-2015, 10:00 AM
Stromthusiast!
 
Join Date: Oct 2014
Location: Massachusetts
Posts: 528
Haven't had that issue, but good luck with Suzuki. I had an issue with the rear axle/nut galling on my 650 at 10 months. Apparently, a not uncommon thing on the bike. I had to use a long pipe for leverage and all the strength I had to get that nut off. Of course the threads were totally destroyed, but the only other alternative was to cut it off. Took the axle and nut to my dealer, said they never heard of it, but sent it in to suzuki. Suzuki said "user error", that I stripped it. Needless to say I was f'n pissed.
mcrag is offline  
post #3 of 5 Old 12-11-2015, 03:35 PM
Stromthusiast!
 
Join Date: Dec 2012
Location: Austin, TX
Posts: 209
I have the same issue...The FI light comes on, it has happened maybe 5-6 times now...Shut the bike off, then back on, light goes away...Good to know that it's just the butterfly valve on the exhaust, if that's the case, no big deal...
jmackd1 is offline  
 
post #4 of 5 Old 12-11-2015, 06:50 PM
Stromthusiast!
 
mr_anonymous's Avatar
 
Join Date: Jun 2015
Location: Hervey Bay
Posts: 246
It can't be that hard to adjust a couple of cables.
I imagine it would not be dissimilar to adjusting throttle cables.
A wee bit of free play on both cables with full range of movement of the butterfly.
RazzleH likes this.
mr_anonymous is offline  
post #5 of 5 Old 12-11-2015, 10:16 PM Thread Starter
Stromthusiast!
 
Join Date: Jun 2015
Posts: 529
Just so stupid. But problem is fixed. Now I know. Wish they something in manual to tell you about it. 105 bucks later. Maybe I can save some forum members some headaches in the future.
RazzleH likes this.
2stroke is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome