Electric problem, Sorry for the long post - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000 from 2002-2012 DL1000 from 2002-2012 (K2-L2)

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-02-2019, 02:53 PM Thread Starter
Stromthusiast!
Junior Trooper
 
Marco Materia's Avatar
 
Join Date: Mar 2019
Posts: 2
Electric problem, Sorry for the long post

hello guys, I have a problem my cluster doesn't work , I changed the direction indicators with new LEDs, the day after my cluster didn't work anymore, the bike is fine all the lights work, but the speedometer odometer clock and level of fuel does not work, I took the bike to the doctor, the relè are ok the wiring is ok, he told me he could not make any diagnosis, the control unit does not give any signal. now I don't know if I have to buy a new cluster or a new ECU or a new bike😟
Marco Materia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-02-2019, 03:56 PM
Stromthusiast!
 
Join Date: Dec 2013
Location: Puget Sound, and Allegheny County (PA)
Posts: 788
Garage
Quote:
Originally Posted by Marco Materia View Post
hello guys, I have a problem my cluster doesn't work , I changed the direction indicators with new LEDs, the day after my cluster didn't work anymore, the bike is fine all the lights work, but the speedometer odometer clock and level of fuel does not work, I took the bike to the doctor, the relè are ok the wiring is ok, he told me he could not make any diagnosis, the control unit does not give any signal. now I don't know if I have to buy a new cluster or a new ECU or a new bike😟
A few points to consider:
(1) Did the "new LEDs" have current limiting resistors, or, were they designed for 12V operation?
(2) How sure are you that everything got plugged back together that came apart during your indicator change-out?
(3) You need a bike doctor whose diagnosis skills extend beyond reading emitted diagnostic codes.
Trepidator is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Givi Trekker Outback 37L panniers/cases review, long book version Mastery Product Reviews 45 10-11-2018 11:27 PM
That post count problem.... Takophiliac Stromtroopers - New member introductions 3 07-01-2016 05:07 PM
electric problem semifastman DL1000 from 2002-2012 3 12-23-2015 06:11 PM
How do I post pictures and video? FAQ & Howto GrayWolf Rules, Forum Support, Help and Information [NOT FOR MOTORCYCLE RELATED QUESTIONS] 2 02-26-2015 05:45 PM
Electric problem help! cip2006is General V-Strom Discussion 9 05-10-2012 10:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome