Speedometer odometer not working - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000 from 2002-2012 DL1000 from 2002-2012 (K2-L2)

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-01-2019, 08:24 AM Thread Starter
Stromthusiast!
Junior Trooper
 
Marco Materia's Avatar
 
Join Date: Mar 2019
Posts: 2
Speedometer odometer not working

Hi guys, i have a Vstrom k2 , i change the indicator whit a new indicator a led, but now my cluster dont work, all the light are ok, but Speedometer odometer Watch indicator of fuel dont working , all the fuse are ok.
Marco Materia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-01-2019, 08:38 PM
Stromthusiast!
Super Trooper!
 
bwringer's Avatar
 
Join Date: Oct 2009
Location: Indy
Posts: 3,311
You might have accidentally pulled the connectors loose.

There's a cable coming from the back of the speedo unit. Push this connector in and make sure it's locked in.

Follow the cable down until you find the connector to the wiring harness and make sure it's plugged in all the way. Make sure the connector is not corroded. Sometimes this connector gets dirty and the metal terminals corrode.

2002 Suzuki DL1000 V-Strom, Dark Metallic Space Blue
1983 Suzuki GS850G, Cosmic Blue
2005 KLR685, Aztec Red - Turd II.2, the ReReTurdening
bwringer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer problems? peedee DL650 and DL650A - 2004 to 2011 9 04-02-2017 08:58 PM
Weird speedometer problem sidleedsrugby Euro Troopers! 6 09-28-2015 07:05 PM
Speedometer or Speedometer Sending unit? madchap DL650 and DL650A - 2004 to 2011 2 08-06-2015 08:33 AM
16 Tooth Countershaft fixes Speedometer! realshelby DL650A - 2012-2016 115 08-07-2014 12:19 PM
Installed Rostra cruise control now speedometer doesn¯t work Rick54 DL650A - 2012-2016 12 10-04-2012 08:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome