Dead battery - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Go Back   Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums > V-Strom Forums > Maintenance, Tech and Farkles.


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2012, 02:09 PM
Stromthusiast!
Junior Trooper
 
Join Date: Sep 2012
Location: Colorado Springs
Posts: 5
Default Dead battery

2009 Wee with original battery. Have had no problems and started it up a couple of days ago. Disconnected it yesterday to do add a bunch of electrical goodies and hooked it back up today and it was completely dead. Dead dead. Would barely light up my test light. Don't have any of the extra electrical goodies hooked up and its been on a trickle charger for the morning. Just time to replace or what could have caused it lose all charge completely disconnected?
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-20-2012, 02:49 PM
kenneth_moore's Avatar
Stromthusiast!
 
Join Date: Nov 2007
Location: Fort Lauderdale FL
Posts: 2,451
Default

The most likely issue is one of the many new electrical goodies you added right before the battery went dead. See what happens without them; if it stays charged, you'll know what the problem is.
__________________
Go hakafugu yourself.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #3  
Old 11-20-2012, 04:11 PM
Stromthusiast!
Junior Trooper
 
Join Date: Sep 2012
Location: Colorado Springs
Posts: 5
Default

Don't have them hooked up and didn't when I hooked up the main battery terminals. Battery just seems to have died completely while disconnected. Really weird.

Quote:
Originally Posted by kenneth_moore View Post
The most likely issue is one of the many new electrical goodies you added right before the battery went dead. See what happens without them; if it stays charged, you'll know what the problem is.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #4  
Old 11-20-2012, 04:23 PM
kenneth_moore's Avatar
Stromthusiast!
 
Join Date: Nov 2007
Location: Fort Lauderdale FL
Posts: 2,451
Default

It's three years old, it may just be dead. When my OEM failed it was very sudden; it didn't "brown out" or anything, it just up and died. Like Mr. BoJangles.
__________________
Go hakafugu yourself.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #5  
Old 11-20-2012, 05:17 PM
Stromthusiast!
 
Join Date: Mar 2012
Location: Deltona, FL
Posts: 73
Default Just its time

As Kenneth said it may have just been its time to go.
Chances are if it was completely dead, while it may recharge, it won't hold the charge very well and probably won't be of much use in the future. I'd replace it and not risk the possibility of being stranded.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #6  
Old 11-20-2012, 05:29 PM
$tromtrooper
 
Join Date: Oct 2009
Location: b'ham, Alabamie...29.4 minutes from Barbers
Posts: 2,149
Default

If you own a 2009 model, chances are it was actually built in 2008........so the battery could be 4 years old. Maybe time for a new one.......

(BTW......my 2008 is still cranking-up strong......maybe it has to do with being inside a conditioned basement most of its life?? Now that I've said that, it will probably die a quick-death next week and leave me stranded in Bumfook, Alabama..... )
__________________
Current Rides: 2008 Yeller Wee + 2000 ZRX1100
Rodney Dangerfield:My psychiatrist told me I was crazy and I said I want a second opinion. He said "okay"...... you're ugly too.
Apparel Security Cables... http://www.stromtrooper.com/group-bu...m-apparel.html and my products-4-sale photo-album http://moto-kafe.smugmug.com/browse
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #7  
Old 11-20-2012, 10:05 PM
Stromthusiast!
Junior Trooper
 
Join Date: Sep 2012
Location: Colorado Springs
Posts: 5
Default

Yep. Not worth messing around with so got another on the way. Never had one die so fast especially while disconnected.
Thanks for the replies.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
  #8  
Old 11-20-2012, 10:06 PM
swoody126's Avatar
Stromthusiast!
Super Trooper!
 
Join Date: Jan 2012
Location: north central Texas
Posts: 334
Default really dead?

i wonder if you could possible have damaged the terminal(s) in the process?

3 years?

bite the bullet & get a new one

check out BATTERIES PLUS

there are 3 in The Springs

they are retail but will take care of your battery needs

while you're at it, put a BATTERY TENDER on also

they do wonders when it comes to extending battery life, specially in the winter

just an old man's 2 worth

sw
__________________
Everyone crashes. Some get back on. Some don't. Some can't.
--------------------------------------------------------
steve
--------------------------------------------------------
'05 WEE (LRW)
'99 DR TREE FIDDY SEX
plus several BRAND X

Last edited by swoody126; 11-20-2012 at 10:08 PM.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2