TRE install on DL1000 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Maintenance How-to WARNING! If you follow these posts and something goes wrong - Stromtroopers is not responsible for any damages, etc. You assume all risk.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 06-17-2010, 01:29 PM Thread Starter
Stromthusiast!
Super Trooper!
 
VBLA427's Avatar
 
Join Date: May 2010
Location: Massachusetts
Posts: 21
TRE install on DL1000

....curious to know what has been other owners' results after installing a TRE on their DL1000?

marked improvement....or waste of $$$?

thanks
VBLA427 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-17-2010, 05:46 PM
Stromthusiast!
Super Trooper!
 
Join Date: Aug 2008
Location: Crown Point, IN
Posts: 75
I installed one on my 2003 SV1000 naked. Same engine as the DL1000. The result was that it did run stronger in the lower gears, but the TRE mod makes the bike a little cold-blooded at startup. Probably not a good idea if you live up north.

If you go to the SV owners forum and do a search, they list instructions for doing the TRE mod using an inexpensive resistor from Radio Shack. I believe I paid about 6 bucks for a whole pack. It took my stepson about 10 minutes to do the install. Was if worth it? Yeah.

Good luck.

Givi crash guards, Suzuki handguards, Madstad bracket, Grip Puppies, mirror extensions, Suzuki tall touring seat, Dan Vessel skid plate and hiway pegs, Givi E21 side bags, Touratech side stand plate, tool tube, turn signal mod,
03 Honda VTX 1800C (Red)
taxbiker is offline  
post #3 of 6 Old 06-17-2010, 05:58 PM
Stromthusiast!
 
bwringer's Avatar
 
Join Date: Oct 2009
Location: Indy
Posts: 2,389
As I understand it, the Ivan's TRE lets through the proper neutral signal so there's no idle issue.

I built one, but I think my solder-fu was bad.

2002 Suzuki DL1000 V-Strom, Dark Metallic Space Blue
1983 Suzuki GS850G, Cosmic Blue
2005 KLR685, Aztec Red - Turd II.2, the ReReTurdening
bwringer is offline  
post #4 of 6 Old 06-18-2010, 08:39 AM
Stromthusiast!
Super Trooper!
 
Chuck0334's Avatar
 
Join Date: Jul 2008
Location: Rio Rancho.New Mexico
Posts: 69
I have one on my 02 Vee and it lets me have all the RPM you want thru all the gears. I love it . I also have a 16 tooth counter shaft and my bike pulls like a freight train. Chuck
Chuck0334 is offline  
post #5 of 6 Old 06-18-2010, 04:06 PM
Stromthusiast!
Super Trooper!
 
Travman's Avatar
 
Join Date: Jul 2009
Location: GA
Posts: 204
I have a GIpro w/ATRE on order and will provide some feedback when I install it next week.

All who wander are not lost!

2008 DL1000 - Silver - gone
2008 Suzuki Burgman 650 Exec - gone
2007 Suzuki Burgman 400 - gone
Travman is offline  
post #6 of 6 Old 06-25-2010, 10:42 AM
Stromthusiast!
Super Trooper!
 
Travman's Avatar
 
Join Date: Jul 2009
Location: GA
Posts: 204
Did the GIpro install

I installed the GIpro w/ATRE this week. So as not to post it twice, here's the link to the thread with the write up.

http://www.stromtrooper.com/showthre...383#post573383

All who wander are not lost!

2008 DL1000 - Silver - gone
2008 Suzuki Burgman 650 Exec - gone
2007 Suzuki Burgman 400 - gone
Travman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome