Help - Strange engine clicking after 1st oil change - Page 3 - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL650A - 2012+ DL 650 2012 +

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 26 Old 12-01-2012, 03:41 AM
Stromthusiast!
 
fortp's Avatar
 
Join Date: Apr 2012
Location: Qc, Canada
Posts: 745
i dont believe a little overfill would cause unusual noise.
fortp is offline  
Sponsored Links
Advertisement
 
post #22 of 26 Old 12-01-2012, 06:39 AM Thread Starter
Stromthusiast!
 
Join Date: Oct 2012
Location: Raleigh, NC
Posts: 13
Quote:
Originally Posted by Sentinel View Post
So how is now, same noise still?
The noise is still there. It only happens at idle with the engine warm. It is not a consistent click pattern. It sounds like a electric relay switch clicking on and off. Yesterday, I noticed it disappears when I slowly release the clutch lever. It also disappears with a little rpms.
mmonce is offline  
post #23 of 26 Old 12-01-2012, 08:04 AM
Stromthusiast!
 
fortp's Avatar
 
Join Date: Apr 2012
Location: Qc, Canada
Posts: 745
It sound normal for me in the video but... if i were you i would prefer rely on the dealer (or live mechanic) than on people far away listening at their computer
fortp is offline  
post #24 of 26 Old 12-01-2012, 09:07 AM
Stromthusiast!
 
om28's Avatar
 
Join Date: Dec 2008
Location: Nashua, NH
Posts: 587
Garage
I just changed the oil on my Wee for winter storage last week, and also had a ticking from the rear cylinder when I started it up. Check the oil level, it was a little little low as some was absorbed by filter, added oil, started bike and ticking was gone. I know some people check the oil with the bike on the centerstand, this gives a false reading since the oil flows to the front of the engine and appears higher in the sight glass than it really is.

2009 Wee Strom ABS (current)
1987 Harley Low Rider Sport (current)
2009 Aprilia Mana 850, 2006 SV650, 1984 Yamaha Virago 1000 (all sold)
Silver Strom Club Member #11

Wee Farkles: SWMotech Centerstand, Framesliders, Forkbrace, Elka Shock, Aprilia mirrors, Fenda Extenda, Suzuki Handguards, Madstad with Moose Adventure Shield +4'', Russell Day Long Seat, Givi XS308 Tankbag.
om28 is offline  
post #25 of 26 Old 12-03-2012, 10:50 AM
Stromthusiast!
 
Join Date: Mar 2012
Location: Minneapolis, MN
Posts: 42
That clicking noise is there on my bike and has been since about 800 miles. I have 3400 on it now and it sounds the same. My dad's adventure also has the same noise. I think it is just valve train noise.
johnny5jz is online now  
post #26 of 26 Old 12-04-2012, 08:20 PM
Stromthusiast!
Super Trooper!
 
JayS's Avatar
 
Join Date: Jun 2012
Location: Providence, RI
Posts: 128
when you revved it the bike sounded the same as my 2012 650 orange 6,500 miles. hasn't changed since i bought it.

but...when you idle i thought i heard a "clicking" since the bike is still under warranty if it puts your mind at ease just take it too the dealer i am one to not take to dealer unless its "broken" if its running fine and all the basics have been checked put on some earphones/interphone music and enjoy!

regards

~~~>Jay<~~~


[SIGPIC][/SIGPIC]
JayS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome