12V Outlet stopped working - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000A - 2014-2016 DL1000A - 2014-2016 (L4-L6)

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-20-2017, 11:47 PM Thread Starter
 
Join Date: Dec 2015
Location: Tellico Plains, United States
Posts: 99
12V Outlet stopped working

I noticed my 12v Outlet is not working. Does anyone know which fuse it is? I don't have the bike with me now so I am not sure if it is on the fuse box cover.
Midwinter is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-20-2017, 11:56 PM
Stromthusiast!
 
Solo Moto's Avatar
 
Join Date: Apr 2014
Location: North Idaho
Posts: 302
Garage
Seriously?!?? A 3 Amp ATM Low Profile Fuse...

Current: '14 DL1000A, '16 DR650SE, '15 DR200S
Past: '07 DL1000, '01 K1200LTC, '89 ZX10, '81 KZ650, '75 DT400B
All I care about is riding... and like, maybe three people... and beer.
Solo Moto is offline  
post #3 of 4 Old 03-21-2017, 12:08 AM
Stromthusiast!
 
Bugzy's Avatar
 
Join Date: May 2011
Posts: 3,371
Bugzy is offline  
 
post #4 of 4 Old 03-21-2017, 08:06 AM
Stromthusiast!
 
Join Date: Oct 2006
Location: KC Area
Posts: 36
Have a shelf on my KLR with two 12 volt sockets. Once in awhile one or the other doesn't work. I usually only have to spin the plug into the socket, must get corroded despite cover caps in place. Might try that.

Lovin' da Strom
tomstromr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome