Interesting news from my Dealer on the 2012 ECM - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
Go Back   Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums > Popular Forums > DL1000 - 2002-2012


DL1000 - 2002-2012 For those bikes with two pipes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2013, 06:25 PM
$tromtrooper
 
Join Date: Aug 2012
Location: West of Atlanta , Ga
Posts: 1,405
Default Interesting news from my Dealer on the 2012 ECM

Swung into my Dealer to discuss the ongoing popping I'm getting in the airbox. Complained originally shortly after the purchase of the bike (1-2 weeks after purchase) , as I would go off road , and it would pop over every small obstacle I crossed (rock veins , roots , etc...). It also does it on the street from time to time. They contacted Suzuki , who said "We've never heard of that complaint". Naturally.

Walked in the door today , and the guys said "Hey , Suzuki has acknowledged your issue , and is going to resolve it". OK...... So , they printed me a bulletin stating that they are changing the ECM (from "early" version to "late" version) and installing Iridium plugs. Parts will be in on Friday , so here's to hoping.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-13-2013, 06:38 PM
scott1000's Avatar
Stromthusiast!
 
Join Date: Sep 2012
Location: Chas. SC
Posts: 176
Default

Good deal, hope that takes care of it. At least they're trying to take care of the issue. If that doesn't fix it, hopefully they'll keep trying
__________________
If you give a Moose a Muff..ler...
Its a Kid thing

Next time I'll put some effort into my username. This one sounds like a toilet Bowl cleaner or Treadmill, or..
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #3  
Old 03-13-2013, 07:59 PM
Stromthusiast!
 
Join Date: Mar 2012
Location: Ohio
Posts: 228
Default

What model year are the bykes with "popping" issues?
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #4  
Old 03-14-2013, 12:10 PM
Stromthusiast!
Junior Trooper
 
Join Date: Mar 2012
Location: Lake Co. FL
Posts: 19
Default

I got a phone call from my dealership yesterday asking if I wanted to be involved in this. Uhhh, yeah. Only question I asked them is about my re-flash. I had my ECU reflashed with a Yosh box and I asked if they would do that again. They said they want to replace the ECU first and see if it needs it. After what I went through with the brakes on my '08 Gixxer (which Suzuki never admitted was a problem) I am hoping this doesn't become a fiasco.
__________________
You give peace a chance. I'll cover you in case that doesn't work out.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #5  
Old 03-14-2013, 03:11 PM
Stromthusiast!
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 121
Default

Again what year bike and is it the 650?
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #6  
Old 03-14-2013, 04:47 PM
$tromtrooper
 
Join Date: Aug 2012
Location: West of Atlanta , Ga
Posts: 1,405
Default

My bad......mine is a 2012 1000.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #7  
Old 03-14-2013, 05:31 PM
greywolf's Avatar
Moderator++
 
Join Date: Jan 2006
Location: Evanston IL
Posts: 29,368
Default

650s don't have lean run issues. I'm moving this thread to the Vee forum.
__________________
Pat- 2007 DL650A was ridden to all 48 contiguous states. 2012 DL650A is just getting started.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014+ DL1000s. Wee = 2004-2011 DL650s. Glee = 2012+ DL650s
See http://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at http://www.stromtrooper.com/informat...-you-have.html
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #8  
Old 03-14-2013, 09:50 PM
Stromthusiast!
 
Join Date: Apr 2012
Location: grove city,ohio
Posts: 32
Default

I have been trying to get this same news out to Vee owners for 2 months. It is and should be the most viewed and talked about fix for the Vee EVER! The new ECU that Suzuki is sending dealers to install on the 2012 is literally fixing every running issue, gas mileage issue, stuttering issue, popping issue etc. that has plagued the Vee since these problems have developed. I had it installed on my 2012 Adventure and have continually stated that it has corrected EVERY problem my bike had. Yet I continue to read complaints from riders asking whats wrong and what can be done. Why not just send a blanket reply to all members that if they are experiencing these types of problems, contact your dealer and get the ECU ordered and installed and spend more time riding and less time posting and asking what can be done? You don't need a PC, you need the new ECU that Suzuki has developed and is giving you for FREE!
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #9  
Old 03-14-2013, 10:52 PM
$tromtrooper
 
Join Date: Aug 2012
Location: West of Atlanta , Ga
Posts: 1,405
Default

Music to my ears............
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
  #10  
Old 03-15-2013, 11:12 AM
Wahoo's Avatar
Stromthusiast!
 
Join Date: Feb 2012
Location: Ohio
Posts: 328
Default

I contacted my dealer about mine sputtering and stalling.

Part(s) have been ordered and I'll schedule an install appointment as soon as they arrive.

How long does it take them to swap out the ECM units anyway ?

In any event, thanks to the OP for the heads up on this one.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2