ECU Problem.. - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
DL1000 - 2002-2012 For those bikes with two pipes

LinkBack Thread Tools Display Modes
post #1 of 6 Old 01-03-2013, 04:02 AM Thread Starter
Junior Trooper
Join Date: Sep 2009
Location: malaysia
Posts: 15
ECU Problem..

Hi guys! Need help & clarifications please..I am from Malaysia and have a DL1K 2003 model (Yellow) bought used (3rd owner). only done less than 35K kms and now facing ECU problem as the bike is having a low rpm surging and stalled when engine runs hot. Have done all the neccessary things as mentioned by the service buletin and had replaced a new complete set of the magneto (magnet & coil) earlier as my magnets came off and damaged the coil and installed a new battery but the problem still exist..I was informed by my local mtrcycle workshop that my bike probably is a UK spec thus the ECU unit is not available in Japan...My part # is 32920-06G20 and what is stamped on the ECU reads F8T95671 MGT054 3219..I have seen in ebay these parts that has the same F8T5671 MGT054 except the last 4 numbers that are different..Do you guys think it can fit to my bike?
xyberguy is offline  
Sponsored Links
post #2 of 6 Old 01-03-2013, 10:32 AM
Join Date: Jan 2010
Location: Baltic, Ct
Posts: 6,625
Make sure you helped yourself first

TPS check or replace
Throttle body sync
Check your the rubber boots throttle to cylinder head
Unplug and then replug every connector

Last is fuel/pressure flow check though normally that would show
up in power at the top end
richw is offline  
post #3 of 6 Old 01-03-2013, 11:47 AM
randyo's Avatar
Join Date: Dec 2006
Location: Farmington, New Hampshire, USA
Posts: 9,459
the ECU will not work properly unless its getting the correct signals (voltage) from the sensors

#1 check sensors
#2 inspect wiring for corrosion

IBA# 9560
07 Strom 1k (8x,xxx miles)
99 SV650 (135,006 miles)
82 XV920R
A man with a gun is a citizen
A man without a gun is a subject
randyo is offline  
post #4 of 6 Old 01-03-2013, 12:28 PM
greywolf's Avatar
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 32,400
Actual ECU problems are rare. The stalling issue is often TPS related and replacement is suggested. The low rpm surging is common due to the lean fuel mapping for emissions control. Careful throttle valve synchronization and TPS adjustment to raise the left dash in dealer mode from -C00 at idle to the high position at about 1800rpm often fixes that. Some bikes need to have the fuel mapping richened if that doesn't fix the problem.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014+ DL1000s. Wee = 2004-2011 DL650s. Glee = 2012+ DL650s

Please vote in the poll on what Strom(s) you have at
greywolf is offline  
post #5 of 6 Old 01-05-2013, 03:50 AM Thread Starter
Junior Trooper
Join Date: Sep 2009
Location: malaysia
Posts: 15
as I've mentioned...did all the things needed to be done 1st (includng what you guys hv said) and as recommended in the Suzuki Service Bulletin..anyways, bought the 2nd hand unit from ebay and hope this would finally ends the issue...
xyberguy is offline  
post #6 of 6 Old 01-09-2013, 10:19 PM
maximilian's Avatar
Join Date: Jul 2010
Location: America's Armpit - SoCal
Posts: 309
Power commander and add more fuel below 4,000 rpm! (though the "hot" running sounds a bit unusual...but if lean enough, I guess so).

'06 KLR650
'78 CB750
'04 DL1000
maximilian is offline  
Sponsored Links

ecu problem

Quick Reply

Register Now

In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome